Bu açık 1 milyon wordpress sitesini ilgilendiriyor


WordPress içerik yönetimi sisteminden faydalanan 1 milyon web sitesi, yeni bir keşfe göre "ciddi" bir güvenlik açığına maruz kalmış olabilir.

Güvenlik açığı, 1 milyondan fazla kişinin kullandığı NextGEN Gallery eklentisinde yer alıyor. Açık geçtiğimiz günlerde onarıldı ancak öncesinde saldırganların sisteme SQL sorgusu göndermesine izin veriyordu. Saldırganlar, belirli koşullar altında bu açıktan faydalanarak web sunucusunun backend veritabanına güçlü komutlar gönderebiliyorlardı. Web güvenliği firması Sucuri'den güvenlik araştırmacısı Slavco Mihajloski, blog'unda bu açığın "oldukça kritik" olduğunu söylüyor ve eklentinin güvenlik açığı taşıyan sürümünü kullananların bir an önce onu güncellemesini öneriyor.

Teknik Detaylar


Saldırganların açıktan faydalanabilmesi için PHP programlama dilinde $container_ids olarak bilinen diziyi oluşturmaları gerekiyor. Güvenilmeyen ziyaretçilerin bunun için galeri URL'sinde küçük değişiklikler yapması yetiyor. Bunun ardından saldırgan, SQL isteğine ek sprintf/printf direktifleri ekleyebiliyor ve $wpdb->prepare'i kullanarak kendine kontrol olanağı sunabiliyor.

Saldırının çalışabilmesi için web sitesinin gönderileri gözden geçirme işlevini etkinleştirmiş olması gerekiyor. Bu durumda saldırgan, sitede bir hesap oluşturup, içerisinde kötü niyetli kod bulunan NextGEN Gallery kodlarını kullanabiliyor.

Sucuri'nin açığın ciddiyet oranı olarak 10 üzerinden 9 verdiği sorun, eklentinin 2.1.79 sürümünde onarıldı. Eklentinin changelog'unda açıktan bahsedilmediği için tehdidin ne kadar yaygın olduğu bilinmiyor.

Kaynaklar:
(*) Chip İnternet
(*) sucuri blog

Blog içeriklerinin temel paylaşım amacı o konuyu tartışmaya açmaktır. Sende fikirlerin ile konu hakkında katkıda bulun.
İfadeleri Gösterİfadeleri Gizle