GNS Network

300000 den Fazla Catch Tema Kurulumu WordPress Eklentilerinde Güvenlik Açığı

300000 den Fazla Catch Tema Kurulumu WordPress Eklentilerinde Güvenlik Açığı

WPScan ve Wordfence'deki güvenlik araştırmacıları, Catch Plugins (Catch Themes, LLC'nin bir bölümü) yayınlanmış ve güvenlik açıklarına sahip on yedi eklenti belirledi. Bu güvenlik açıkları yüksek olarak derecelendirilir ve bir saldırganın eklenti yapılandırmalarını değiştirmesine neden olabilir.

Siteler Arası İstek Sahteciliği (CSRF)

Bir kullanıcı kimlik doğrulaması açığı (yetenek kontrolünden yoksun) ve Siteler Arası İstek Sahteciliği (CSRF) güvenlik açığı, Catch Themes tarafından yayınlanan 17 eklentiyi etkiliyor. Bu güvenlik açıkları, oturum açmış herhangi bir kullanıcının, hatta bir abonenin, genellikle web sitesinin yöneticisi gibi en yüksek düzenleme ayrıcalıklarına sahip WordPress kullanıcıları için ayrılmış değişiklikleri gerçekleştirmesine izin verir. WordPress güvenlik eklentisi yayıncısı WPScan'a göre:

"CatchThemes satıcısından gelen Çoklu Eklentiler, ctp_switch AJAX eyleminde, Abone gibi kimliği doğrulanmış herhangi bir kullanıcının eklentinin yapılandırmalarını değiştirmesine izin verebilecek yetenek ve CSRF kontrolleri gerçekleştirmez."

Wordfence, Catch Demo Import WordPress Eklentisindeki Güvenlik Açığı Raporladı

Wordfence, bu eklentilerden birinde de keşfedilen kritik bir güvenlik açığı hakkında bir bildirim yayınladı, Catch Themes Demo Import (sürüm 1.7'ye kadar olan sürümler). Catch Themes Demo Import WordPress eklentisinin Keyfi Dosya Yükleme Güvenlik Açığı olduğu bulundu . Bu özel güvenlik açığının ne kadar ciddi olduğu belli değil. Güvenlik açığı, Wordfence tarafından 1 - 10 arasında 9.1 olarak derecelendirildi ve Kritik olarak tanımlandı. Ancak güvenlik açığı, ABD hükümeti Ulusal Güvenlik Açığı Veritabanında 7,2 (Yüksek) derecesiyle listelendi. Wordfence'e göre:

"Catch Themes Demo Import WordPress eklentisi, yetersiz dosya türü doğrulaması nedeniyle ~/inc/CatchThemesDemoImport.php dosyasında, 1.7'ye kadar ve dahil olmak üzere sürümlerde bulunan içe aktarma işlevi aracılığıyla rastgele dosya yüklemelerine karşı savunmasızdır"

Wordfence, 1.8 veya daha yeni bir sürüme yükseltme yapmanızı önerir.

Onyedi Catch Temasında Bulunan Güvenlik Açıkları WordPress Eklentileri

WPScan, güvenlik açıklarına sahip olduğu keşfedilen on yedi Catch Themes WordPress eklentisini listeler. Tüm on yedi eklenti yayıncısına ifşa edildi ve düzeltildi.

300.000'den Fazla Kurulum Etkilendi

On yedi eklentinin çoğu oldukça popülerdir. Bunlar, yanlarında listelenen kurulum sayısı ile en popüler 10 Catch Themes eklentisidir.

En Popüler On Vulnerable Catch Tema Eklentisi

  • To Top – 80,000 Installations
  • Essential Content Types – 50,000 Installations
  • Catch IDs – 40,000 Installations
  • Catch Web Tools – 20,000 Installations
  • Social Gallery and Widget – 20,000 Installations
  • Catch Infinite Scroll – 20,000 Installations
  • Catch Gallery – 20,000 Installations
  • Essential Widgets – 20,000 Installations
  • Catch Instagram Feed Gallery & Widget (Social Gallery and Widget) – 20,000 Installations
  • Catch Themes Demo Import – 10,000 Installations

Onyedi Catch Teması Savunmasız Eklentiler

Bunlar, WPScan tarafından daha sonra yamalanan bir güvenlik açığına sahip olduğu bildirilen on yedi eklentidir:

  • Essential Widgets Fixed in version 1.9
  • To Top Fixed in version 2.3
  • Header Enhancement Fixed in version 1.5
  • Generate Child Theme Fixed in version 1.6
  • Essential Content Types Fixed in version 1.9
  • Catch Web Tools Fixed in version 2.7
  • Catch Under Construction Fixed in version 1.4
  • Catch Themes Demo Import Fixed in version 1.6
  • Catch Sticky Menu Fixed in version 1.7
  • Catch Scroll Progress Bar Fixed in version 1.6
  • Catch Instagram Feed Gallery & Widget (Social Gallery and Widget) Fixed in version 2.3
  • Catch Infinite Scroll Fixed in version 1.9
  • Catch Import Export Fixed in version 1.9
  • Catch Gallery Fixed in version 1.7
  • Catch Duplicate Switcher Fixed in version 1.6
  • Catch Breadcrumb Fixed in version 1.7
  • Catch IDs Fixed in version 2.4

Kullanıcıların En Son Eklenti Sürümlerini Güncellemeyi Düşünmeleri Tavsiye Edilir

Etkilenen Catch Themes eklentilerini kullanan ve bu eklentilerin savunmasız sürümlerini kullanmanın istenmeyen sonuçlarından kaçınmak isteyen yayıncılar, eklentilerin şu anda mevcut olan en son sürümlerine yükseltme yapmayı düşünmelidir. Bunun yapılmaması, bir bilgisayar korsanlığı olayına gereksiz yere maruz kalınmasına neden olabilir.

Blog içeriklerinin temel paylaşım amacı o konuyu tartışmaya açmaktır. Sende fikirlerin ile konu hakkında katkıda bulun.
İfadeleri Gösterİfadeleri Gizle